In short
- CVE-2024-25983 is a MEDIUM (CVSS 5.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 48.9% of all vulnerabilities.
- Fix: update to 4.2.6, 4.3.3, 4.1.9 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.2.0, < 4.2.6≥ 4.3.0, < 4.3.3< 4.1.9
| 4.2.64.3.34.1.9
|
| moodle | ≥ 4.1.0, < 4.1.9≥ 4.2.0, < 4.2.6≥ 4.3.0, < 4.3.3
| 4.1.94.2.64.3.3
|
Description
Insufficient checks in a web service made it possible to add comments to the comments block on another user's dashboard when it was not otherwise available (e.g., on their profile page).
NVD description
Insufficient checks in a web service made it possible to add comments to the comments block on another user's dashboard when it was not otherwise available (e.g., on their profile page).
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free