In short
- CVE-2024-26140 is a MEDIUM (CVSS 6.1) vulnerability affecting com.yetanalytics:lrs, lrs (yetanalytics), sql lrs (yetanalytics).
- Chance of exploitation in the next 30 days (EPSS): 0.45%, higher than 39.1% of all vulnerabilities.
- Fix: update to 1.2.17, 0.7.5 or later.
Description
Impact
A maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser.
Patches
The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS.
Workarounds
No workarounds exist, we recommend upgrading to version 1.2.17 of the library or version 0.7.5 of SQL LRS immediately.
References
NVD description
com.yetanalytics/lrs is the Yet Analytics Core LRS Library. Prior to version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS, a maliciously crafted xAPI statement could be used to perform script or other tag injection in the LRS Statement Browser. The problem is patched in version 1.2.17 of the LRS library and version 0.7.5 of SQL LRS. No known workarounds exist.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free