In short
- CVE-2024-2660 is a MEDIUM (CVSS 6.8) vulnerability affecting github.com/hashicorp/vault, vault (hashicorp).
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 23.1% of all vulnerabilities.
- Fix: update to 1.16.0, 1.14.11, 1.15.7 or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | < 1.16.0
| 1.16.0
|
| vault | ≥ 1.14.0, < 1.14.11≥ 1.14.0, < 1.16.0≥ 1.15.0, < 1.15.7
| 1.14.111.16.01.15.7
|
Description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. Fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
NVD description
Vault and Vault Enterprise TLS certificates auth method did not correctly validate OCSP responses when one or more OCSP sources were configured. This vulnerability, CVE-2024-2660, affects Vault and Vault Enterprise 1.14.0 and above, and is fixed in Vault 1.16.0 and Vault Enterprise 1.16.1, 1.15.7, and 1.14.11.
More vulnerabilities in github.com/hashicorp/vault
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free