In short
- CVE-2024-27097 is a MEDIUM (CVSS 5.3) vulnerability affecting ckan, ckan (okfn).
- Chance of exploitation in the next 30 days (EPSS): 0.44%, higher than 38.0% of all vulnerabilities.
- Fix: update to 2.10.4, 2.9.11 or later.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.10.0, < 2.10.4< 2.9.11
| 2.10.42.9.11
|
| ckan | ≥ 2.0, < 2.9.11≥ 2.10.0, < 2.10.4
| 2.9.112.10.4
|
Description
A user endpoint didn't perform filtering on an incoming parameter, which was added directly to the application log. This could lead to an attacker injecting false log entries or corrupt the log file format.
Patches
This has been fixed in the CKAN 2.9.11 and 2.10.4 versions
Workarounds
Override the /user/reset endpoint to filter the id parameter in order to exclude newlines
NVD description
A user endpoint didn't perform filtering on an incoming parameter, which was added directly to the application log. This could lead to an attacker injecting false log entries or corrupt the log file format. This has been fixed in the CKAN versions 2.9.11 and 2.10.4. Users are advised to upgrade. Users unable to upgrade should override the `/user/reset` endpoint to filter the `id` parameter in order to exclude newlines.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free