In short
- CVE-2024-27132 is a CRITICAL (CVSS 9.6) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.88%, higher than 59.1% of all vulnerabilities.
- Fix: update to 2.10.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.10.0
| 2.10.0
|
| mlflow | ≤ 2.9.2
| No fix yet |
Description
Insufficient sanitization in MLflow leads to XSS when running an untrusted recipe.
This issue leads to a client-side RCE when running an untrusted recipe in Jupyter Notebook.
The vulnerability stems from lack of sanitization over template variables.
NVD description
Insufficient sanitization in MLflow leads to XSS when running an untrusted recipe.
This issue leads to a client-side RCE when running an untrusted recipe in Jupyter Notebook.
The vulnerability stems from lack of sanitization over template variables.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free