In short
- CVE-2024-27133 is a CRITICAL (CVSS 9.6) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.66%, higher than 51.4% of all vulnerabilities.
- Fix: update to 2.10.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.10.0
| 2.10.0
|
| mlflow | ≤ 2.9.2
| No fix yet |
Description
Insufficient sanitization in MLflow leads to XSS when running a recipe that uses an untrusted dataset. This issue leads to a client-side RCE when running the recipe in Jupyter Notebook. The vulnerability stems from lack of sanitization over dataset table fields.
NVD description
Insufficient sanitization in MLflow leads to XSS when running a recipe that uses an untrusted dataset. This issue leads to a client-side RCE when running the recipe in Jupyter Notebook. The vulnerability stems from lack of sanitization over dataset table fields.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free