In short
- CVE-2024-27134 is a HIGH (CVSS 7.0) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.12%, higher than 1.9% of all vulnerabilities.
- Fix: update to 2.16.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.16.0
| 2.16.0
|
| mlflow | < 2.16.0
| 2.16.0
|
Description
Excessive directory permissions in MLflow leads to local privilege escalation when using spark_udf. This behavior can be exploited by a local attacker to gain elevated permissions by using a ToCToU attack. The issue is only relevant when the spark_udf() MLflow API is called.
NVD description
Excessive directory permissions in MLflow leads to local privilege escalation when using spark_udf. This behavior can be exploited by a local attacker to gain elevated permissions by using a ToCToU attack. The issue is only relevant when the spark_udf() MLflow API is called.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free