In short
- CVE-2024-27306 is a MEDIUM (CVSS 6.1) vulnerability affecting aiohttp, aiohttp (aiohttp).
- Chance of exploitation in the next 30 days (EPSS): 0.67%, higher than 51.8% of all vulnerabilities.
- Fix: update to 3.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| aiohttp PyPI | < 3.9.4
| 3.9.4
|
| aiohttp | < 3.9.4
| 3.9.4
|
Description
Summary
A XSS vulnerability exists on index pages for static file handling.
Details
When using web.static(..., show_index=True), the resulting index pages do not escape file names.
If users can upload files with arbitrary filenames to the static directory, the server is vulnerable to XSS attacks.
Workaround
We have always recommended using a reverse proxy server (e.g. nginx) for serving static files. Users following the recommendation are unaffected.
Other users can disable show_index if unable to upgrade.
Patch: https://github.com/aio-libs/aiohttp/pull/8319/files
NVD description
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server (e.g. nginx) for serving static files. Users following the recommendation are unaffected. Other users can disable `show_index` if unable to upgrade.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free