In short
- CVE-2024-27318 is a HIGH (CVSS 7.5) vulnerability affecting onnx, onnx (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.9% of all vulnerabilities.
- Fix: update to 1.16.0 or later.
| Package | Affected versions | Patched versions |
|---|
| onnx PyPI | < 1.16.0
| 1.16.0
|
| onnx | < 1.16.0
| 1.16.0
|
Description
Versions of the package onnx before and including 1.15.0 are vulnerable to Directory Traversal as the external_data field of the tensor proto can have a path to the file which is outside the model current directory or user-provided directory. The vulnerability occurs as a bypass for the patch added for CVE-2022-25882.
NVD description
Versions of the package onnx before and including 1.15.0 are vulnerable to Directory Traversal as the external_data field of the tensor proto can have a path to the file which is outside the model current directory or user-provided directory. The vulnerability occurs as a bypass for the patch added for CVE-2022-25882.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free