In short
- CVE-2024-27319 is a CRITICAL (CVSS 9.1) vulnerability affecting onnx, onnx (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.2% of all vulnerabilities.
- Fix: update to 1.16.0 or later.
| Package | Affected versions | Patched versions |
|---|
| onnx PyPI | < 1.16.0
| 1.16.0
|
| onnx | < 1.16.0
| 1.16.0
|
Description
Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.
NVD description
Versions of the package onnx before and including 1.15.0 are vulnerable to Out-of-bounds Read as the ONNX_ASSERT and ONNX_ASSERTM functions have an off by one string copy.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free