In short
- CVE-2024-29027 is a CRITICAL (CVSS 9.0) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.9% of all vulnerabilities.
- Fix: update to 6.5.5, 7.0.0-alpha.29 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 7.0.0< 6.5.5
| 6.5.5
|
| parse-server npm | ≥ 7.0.0-alpha.1, < 7.0.0-alpha.29< 6.5.5
| 7.0.0-alpha.296.5.5
|
Description
Impact
Calling an invalid Parse Server Cloud Function name or Cloud Job name crashes server and may allow for code injection.
Patches
Added string sanitation for Cloud Function name and Cloud Job name.
Workarounds
Sanitize the Cloud Function name and Cloud Job name before it reaches Parse Server.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 6.5.5 and 7.0.0-alpha.29, calling an invalid Parse Server Cloud Function name or Cloud Job name crashes the server and may allow for code injection, internal store manipulation or remote code execution. The patch in versions 6.5.5 and 7.0.0-alpha.29 added string sanitation for Cloud Function name and Cloud Job name. As a workaround, sanitize the Cloud Function name and Cloud Job name before it reaches Parse Server.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free