In short
- CVE-2024-31621 is a HIGH (CVSS 7.6) vulnerability affecting flowise (flowiseai), flowise.
- Chance of exploitation in the next 30 days (EPSS): 59.9%, higher than 99.1% of all vulnerabilities.
- Fix: update to 1.8.1 or later.
| Package | Affected versions | Patched versions |
|---|
| flowise | ≤ 1.6.5
| No fix yet |
| flowise npm | < 1.8.1
| 1.8.1
|
Description
An issue in FlowiseAI Inc Flowise prior to v1.8.1 allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.
NVD description
An issue in FlowiseAI Inc Flowise v.1.6.2 and before allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free