In short
- CVE-2024-32005 is a HIGH (CVSS 8.2) vulnerability affecting nicegui.
- Chance of exploitation in the next 30 days (EPSS): 0.76%, higher than 55.3% of all vulnerabilities.
- Fix: update to 1.4.21 or later.
| Package | Affected versions | Patched versions |
|---|
| nicegui PyPI | ≥ 1.4.6, < 1.4.21
| 1.4.21
|
Description
NiceGUI is an easy-to-use, Python-based UI framework. A local file inclusion is present in the NiceUI leaflet component when requesting resource files under the /_nicegui/{__version__}/resources/{key}/{path:path} route.
As a result any file on the backend filesystem which the web server has access to can be read by an attacker with access to the NiceUI leaflet website.
This vulnerability has been addressed in version 1.4.21. Users are advised to upgrade. There are no known workarounds for this vulnerability.
NVD description
NiceGUI is an easy-to-use, Python-based UI framework. A local file inclusion is present in the NiceUI leaflet component when requesting resource files under the `/_nicegui/{__version__}/resources/{key}/{path:path}` route. As a result any file on the backend filesystem which the web server has access to can be read by an attacker with access to the NiceUI leaflet website. This vulnerability has been addressed in version 1.4.21. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free