In short
- CVE-2024-32034 is a MEDIUM (CVSS 4.8) vulnerability affecting decidim-admin, decidim (decidim).
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 31.4% of all vulnerabilities.
- Fix: update to 0.28.2, 0.27.7 or later.
| Package | Affected versions | Patched versions |
|---|
| decidim-admin RubyGems | ≥ 0.28.0, < 0.28.2< 0.27.7
| 0.28.20.27.7
|
| decidim | = 0.28.0= 0.28.1< 0.27.7
| 0.27.7
|
Description
Impact
The admin panel is subject to potential XSS attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted.
Patches
N/A
Workarounds
Redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. /admin/organization/edit)
References
OWASP ASVS v4.0.3-5.1.3
NVD description
decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. The admin panel is subject to potential Cross-site scripting (XSS) attach in case an admin assigns a valuator to a proposal, or does any other action that generates an admin activity log where one of the resources has an XSS crafted. This issue has been addressed in release version 0.27.7, 0.28.2, and newer. Users are advised to upgrade. Users unable to upgrade may redirect the pages /admin and /admin/logs to other admin pages to prevent this access (i.e. `/admin/organization/edit`).
More vulnerabilities in decidim-admin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free