In short
- CVE-2024-33996 is a MEDIUM (CVSS 6.2) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.37%, higher than 31.4% of all vulnerabilities.
- Fix: update to 4.2.7, 4.3.4, 4.1.10 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
| moodle | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
Description
Incorrect validation of allowed event types in a calendar web service made it possible for some users to create events with types/audiences they did not have permission to publish to.
NVD description
Incorrect validation of allowed event types in a calendar web service made it possible for some users to create events with types/audiences they did not have permission to publish to.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free