In short
- CVE-2024-33999 is a CRITICAL (CVSS 9.8) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.55%, higher than 45.8% of all vulnerabilities.
- Fix: update to 4.3.4 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.3.0, < 4.3.4
| 4.3.4
|
| moodle | ≥ 4.3.0, < 4.3.4
| 4.3.4
|
Description
Unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php. The referrer URL used by MFA required additional sanitizing, rather than being used directly.
NVD description
The referrer URL used by MFA required additional sanitizing, rather than being used directly.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free