In short
- CVE-2024-34005 is a MEDIUM (CVSS 6.5) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.4% of all vulnerabilities.
- Fix: update to 4.2.7, 4.3.4, 4.1.10 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
| moodle | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
Description
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore database activity modules and direct access to the web server outside of the Moodle webroot could execute a local file include.
NVD description
In a shared hosting environment that has been misconfigured to allow access to other users' content, a Moodle user with both access to restore database activity modules and direct access to the web server outside of the Moodle webroot could execute a local file include.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free