In short
- CVE-2024-34006 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 29.3% of all vulnerabilities.
- Fix: update to 4.2.7, 4.3.4, 4.1.10 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
| moodle | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
Description
The site log report required additional encoding of event descriptions to ensure any HTML in the content is displayed in plaintext instead of being rendered.
NVD description
The site log report required additional encoding of event descriptions to ensure any HTML in the content is displayed in plaintext instead of being rendered.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free