In short
- CVE-2024-34007 is a HIGH (CVSS 8.8) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 29.3% of all vulnerabilities.
- Fix: update to 4.3.4 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.3.0, < 4.3.4
| 4.3.4
|
| moodle | ≥ 4.3.0, < 4.3.4
| 4.3.4
|
Description
The logout option within MFA did not include the necessary token to avoid the risk of users inadvertently being logged out via CSRF.
NVD description
The logout option within MFA did not include the necessary token to avoid the risk of users inadvertently being logged out via CSRF.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free