In short
- CVE-2024-34008 is a HIGH (CVSS 8.8) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.40%, higher than 34.1% of all vulnerabilities.
- Fix: update to 4.2.7, 4.3.4, 4.1.10 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 4.2.0, < 4.2.7≥ 4.3.0, < 4.3.4< 4.1.10
| 4.2.74.3.44.1.10
|
| moodle | ≥ 4.0, < 4.3.4≥ 4.1, < 4.1.10≥ 4.2, < 4.2.7
| 4.3.44.1.104.2.7
|
Description
Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.
NVD description
Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free