In short
- CVE-2024-34156 is a HIGH (CVSS 7.5) vulnerability affecting stdlib.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.3% of all vulnerabilities.
- Fix: update to 1.23.1, 1.22.7 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.23.0-0, < 1.23.1< 1.22.7
| 1.23.11.22.7
|
Description
Calling Decoder.Decode on a message which contains deeply nested structures can cause a panic due to stack exhaustion. This is a follow-up to CVE-2022-30635.
NVD description
Calling Decoder.Decode on a message which contains deeply nested structures can cause a panic due to stack exhaustion. This is a follow-up to CVE-2022-30635.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free