In short
- CVE-2024-34158 is a HIGH (CVSS 7.5) vulnerability affecting stdlib.
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.2% of all vulnerabilities.
- Fix: update to 1.23.1, 1.22.7 or later.
| Package | Affected versions | Patched versions |
|---|
| stdlib Go | ≥ 1.23.0-0, < 1.23.1< 1.22.7
| 1.23.11.22.7
|
Description
Calling Parse on a "// +build" build tag line with deeply nested expressions can cause a panic due to stack exhaustion.
NVD description
Calling Parse on a "// +build" build tag line with deeply nested expressions can cause a panic due to stack exhaustion.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free