In short
- CVE-2024-34355 is a MEDIUM (CVSS 5.4) vulnerability affecting typo3/cms-core, typo3 (typo3).
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.0% of all vulnerabilities.
- Fix: update to 13.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| typo3/cms-core Packagist | ≥ 13.0.0, < 13.1.1
| 13.1.1
|
| typo3 | ≥ 13.0.0, < 13.1.1
| 13.1.1
|
Description
Problem
The history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account.
Solution
Update to TYPO3 version 13.1.1 that fixes the problem described.
Credits
Thanks to TYPO3 core team member Andreas Kienast who reported this issue and to TYPO3 core & security team Benjamin Franzke who fixed the issue.
References
NVD description
TYPO3 is an enterprise content management system. Starting in version 13.0.0 and prior to version 13.1.1, the history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account. TYPO3 version 13.1.1 fixes the problem described.
More vulnerabilities in typo3/cms-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free