In short
- CVE-2024-34478 is a HIGH (CVSS 7.5) vulnerability affecting github.com/btcsuite/btcd, btcd (btcd project).
- Chance of exploitation in the next 30 days (EPSS): 0.56%, higher than 46.5% of all vulnerabilities.
- Fix: update to 0.24.0 or later.
Description
btcd before 0.24.0 does not correctly implement the consensus rules outlined in BIP 68 and BIP 112, making it susceptible to consensus failures. Specifically, it uses the transaction version as a signed integer when it is supposed to be treated as unsigned. There can be a chain split and loss of funds.
NVD description
btcd before 0.24.0 does not correctly implement the consensus rules outlined in BIP 68 and BIP 112, making it susceptible to consensus failures. Specifically, it uses the transaction version as a signed integer when it is supposed to be treated as unsigned. There can be a chain split and loss of funds.
More vulnerabilities in github.com/btcsuite/btcd
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free