In short
- CVE-2024-35178 is a HIGH (CVSS 7.5) vulnerability affecting jupyter-server, jupyter server (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 0.80%, higher than 56.7% of all vulnerabilities.
- Fix: update to 2.14.1 or later.
Description
Summary
Jupyter Server on Windows has a vulnerability that lets unauthenticated attackers leak the NTLMv2 password hash of the Windows user running the Jupyter server. An attacker can crack this password to gain access to the Windows machine hosting the Jupyter server, or access other network-accessible machines or 3rd party services using that credential. Or an attacker perform an NTLM relay attack without cracking the credential to gain access to other network-accessible machines.
NVD description
The Jupyter Server provides the backend for Jupyter web applications. Jupyter Server on Windows has a vulnerability that lets unauthenticated attackers leak the NTLMv2 password hash of the Windows user running the Jupyter server. An attacker can crack this password to gain access to the Windows machine hosting the Jupyter server, or access other network-accessible machines or 3rd party services using that credential. Or an attacker perform an NTLM relay attack without cracking the credential to gain access to other network-accessible machines. This vulnerability is fixed in 2.14.1.
More vulnerabilities in jupyter-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free