In short
- CVE-2024-35241 is a HIGH (CVSS 8.8) vulnerability affecting composer/composer.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.3% of all vulnerabilities.
- Fix: update to 2.2.24, 2.7.7 or later.
| Package | Affected versions | Patched versions |
|---|
| composer/composer Packagist | ≥ 2.0, < 2.2.24≥ 2.3, < 2.7.7
| 2.2.242.7.7
|
Description
Impact
The status, reinstall and remove commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code.
Patches
2.2.24 for 2.2 LTS or 2.7.7 for mainline
Workarounds
Avoid installing dependencies via git by using --prefer-dist or the preferred-install: dist config setting.
NVD description
Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `status`, `reinstall` and `remove` commands with packages installed from source via git containing specially crafted branch names in the repository can be used to execute code. Patches for this issue are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid installing dependencies via git by using `--prefer-dist` or the `preferred-install: dist` config setting.
More vulnerabilities in composer/composer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free