In short
- CVE-2024-35242 is a HIGH (CVSS 8.8) vulnerability affecting composer/composer.
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.4% of all vulnerabilities.
- Fix: update to 2.2.24, 2.7.7 or later.
| Package | Affected versions | Patched versions |
|---|
| composer/composer Packagist | ≥ 2.0, < 2.2.24≥ 2.3, < 2.7.7
| 2.2.242.7.7
|
Description
Impact
The composer install command running inside a git/hg repository which has specially crafted branch names can lead to command injection. So this requires cloning untrusted repositories.
Patches
2.2.24 for 2.2 LTS or 2.7.7 for mainline
Workarounds
Avoid cloning potentially compromised repositories.
NVD description
Composer is a dependency manager for PHP. On the 2.x branch prior to versions 2.2.24 and 2.7.7, the `composer install` command running inside a git/hg repository which has specially crafted branch names can lead to command injection. This requires cloning untrusted repositories. Patches are available in version 2.2.24 for 2.2 LTS or 2.7.7 for mainline. As a workaround, avoid cloning potentially compromised repositories.
More vulnerabilities in composer/composer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free