In short
- CVE-2024-3573 is a CRITICAL (CVSS 9.3) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.73%, higher than 54.4% of all vulnerabilities.
- Fix: update to 2.10.0 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 2.10.0
| 2.10.0
|
| mlflow | < 2.10.0
| 2.10.0
|
Description
mlflow/mlflow is vulnerable to Local File Inclusion (LFI) due to improper parsing of URIs, allowing attackers to bypass checks and read arbitrary files on the system. The issue arises from the 'is_local_uri' function's failure to properly handle URIs with empty or 'file' schemes, leading to the misclassification of URIs as non-local. Attackers can exploit this by crafting malicious model versions with specially crafted 'source' parameters, enabling the reading of sensitive files within at least two directory levels from the server's root.
NVD description
mlflow/mlflow is vulnerable to Local File Inclusion (LFI) due to improper parsing of URIs, allowing attackers to bypass checks and read arbitrary files on the system. The issue arises from the 'is_local_uri' function's failure to properly handle URIs with empty or 'file' schemes, leading to the misclassification of URIs as non-local. Attackers can exploit this by crafting malicious model versions with specially crafted 'source' parameters, enabling the reading of sensitive files within at least two directory levels from the server's root.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free