In short
- CVE-2024-36120 is a HIGH (CVSS 7.8) vulnerability affecting javascript deobfuscator (deobfuscate), js-deobfuscator.
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.7% of all vulnerabilities.
- Fix: update to 1.1.0 or later.
Description
javascript-deobfuscator removes common JavaScript obfuscation techniques. Crafted payloads targeting expression simplification can lead to code execution. This issue has been patched in version 1.1.0.
NVD description
javascript-deobfuscator removes common JavaScript obfuscation techniques. In affected versions crafted payloads targeting expression simplification can lead to code execution. This issue has been patched in version 1.1.0. Users are advised to update. Users unable to upgrade should disable the expression simplification feature.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free