In short
- CVE-2024-36128 is a HIGH (CVSS 7.5) vulnerability affecting directus (monospace), directus.
- Chance of exploitation in the next 30 days (EPSS): 0.62%, higher than 49.7% of all vulnerabilities.
- Fix: update to 10.11.2 or later.
| Package | Affected versions | Patched versions |
|---|
| directus | < 10.11.2
| 10.11.2
|
| directus npm | < 10.11.2
| 10.11.2
|
Description
Describe the Bug
Providing a non-numeric length value to the random string generation utility will create a memory issue breaking the capability to generate random strings platform wide. This creates a denial of service situation where logged in sessions can no longer be refreshed as sessions depend on the capability to generate a random session ID.
To Reproduce
- Test if the endpoint is working and accessible,
GET http://localhost:8055/utils/random/string
- Do a bad request
GET http://localhost:8055/utils/random/string?length=foo
- After this all calls to
GET http://localhost:8055/utils/random/string will return an empty string instead of a random string
- In this error situation you'll see authentication refreshes fail for the app and api.
Impact
This counts as an unauthenticated denial of service attack vector so this impacts all unpatched instances reachable over the internet.
NVD description
Directus is a real-time API and App dashboard for managing SQL database content. Prior to 10.11.2, providing a non-numeric length value to the random string generation utility will create a memory issue breaking the capability to generate random strings platform wide. This creates a denial of service situation where logged in sessions can no longer be refreshed as sessions depend on the capability to generate a random session ID. This vulnerability is fixed in 10.11.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free