In short
- CVE-2024-36361 is a MEDIUM (CVSS 6.8) vulnerability affecting pug, pug-code-gen.
- Chance of exploitation in the next 30 days (EPSS): 0.49%, higher than 42.4% of all vulnerabilities.
- Fix: update to 3.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| pug npm | < 3.0.3
| 3.0.3
|
| pug-code-gen npm | < 3.0.3
| 3.0.3
|
Description
Pug through 3.0.2 allows JavaScript code execution if an application accepts untrusted input for the name option of the compileClient, compileFileClient, or compileClientWithDependenciesTracked function. NOTE: these functions are for compiling Pug templates into JavaScript, and there would typically be no reason to allow untrusted callers.
NVD description
Pug through 3.0.2 allows JavaScript code execution if an application accepts untrusted input for the name option of the compileClient, compileFileClient, or compileClientWithDependenciesTracked function. NOTE: these functions are for compiling Pug templates into JavaScript, and there would typically be no reason to allow untrusted callers.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free