In short
- CVE-2024-3660 is a CRITICAL (CVSS 9.8) vulnerability affecting keras, keras (keras).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.8% of all vulnerabilities.
- Fix: update to 2.13.1rc0, 2.13.1 or later.
| Package | Affected versions | Patched versions |
|---|
| keras PyPI | < 2.13.1rc0
| 2.13.1rc0
|
| keras | < 2.13.1
| 2.13.1
|
Description
A arbitrary code injection vulnerability in TensorFlow's Keras framework (<2.13) allows attackers to execute arbitrary code with the same permissions as the application using a model that allow arbitrary code irrespective of the application.
NVD description
A arbitrary code injection vulnerability in TensorFlow's Keras framework (<2.13) allows attackers to execute arbitrary code with the same permissions as the application using a model that allow arbitrary code irrespective of the application.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free