In short
- CVE-2024-36858 is a CRITICAL (CVSS 9.8) vulnerability affecting jan (homebrew), @janhq/core.
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.6% of all vulnerabilities.
- No patched version is listed yet: follow the vendor's advisory in References.
| Package | Affected versions | Patched versions |
|---|
| jan | = 0.4.12
| No fix yet |
| @janhq/core npm | ≤ 0.1.11
| No fix yet |
Description
An arbitrary file upload vulnerability in the /v1/app/writeFileSync interface of Jan v0.4.12 allows attackers to execute arbitrary code via uploading a crafted file. @janhq/core has been deprecated in favor of janhq/jan, this vulnerability has been patched there in v0.5.2.
NVD description
An arbitrary file upload vulnerability in the /v1/app/writeFileSync interface of Jan v0.4.12 allows attackers to execute arbitrary code via uploading a crafted file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free