| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.nifi:nifi-web-ui | ≥ 1.10.0, < 1.27.0≥ 2.0.0-M1, < 2.0.0-M4 | 1.27.02.0.0-M4 |
| nifi | = 2.0.0≥ 1.10.0, < 1.27.0 | 1.27.0 |
Apache NiFi 1.10.0 through 1.26.0 and 2.0.0-M1 through 2.0.0-M3 support a description field in the Parameter Context configuration that is vulnerable to cross-site scripting. An authenticated user, authorized to configure a Parameter Context, can enter arbitrary JavaScript code, which the client browser will execute within the session context of the authenticated user. Upgrading to Apache NiFi 1.27.0 or 2.0.0-M4 is the recommended mitigation.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free