In short
- CVE-2024-37896 is a HIGH (CVSS 8.8) vulnerability affecting github.com/flipped-aurora/gin-vue-admin.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.8% of all vulnerabilities.
- Fix: update to 2.6.6+incompatible or later.
Description
SQL injection vulnerability in Gin-vue-admin in github.com/flipped-aurora/gin-vue-admin
NVD description
Gin-vue-admin is a backstage management system based on vue and gin. Gin-vue-admin <= v2.6.5 has SQL injection vulnerability. The SQL injection vulnerabilities occur when a web application allows users to input data into SQL queries without sufficiently validating or sanitizing the input. Failing to properly enforce restrictions on user input could mean that even a basic form input field can be used to inject arbitrary and potentially dangerous SQL commands. This could lead to unauthorized access to the database, data leakage, data manipulation, or even complete compromise of the database server. This vulnerability has been addressed in commit `53d033821` which has been included in release version 2.6.6. Users are advised to upgrade. There are no known workarounds for this vulnerability.
More vulnerabilities in github.com/flipped-aurora/gin-vue-admin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free