In short
- CVE-2024-38821 is a CRITICAL (CVSS 9.1) vulnerability affecting org.springframework.security:spring-security-web.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.8% of all vulnerabilities.
- Fix: update to 5.7.13, 5.8.15, 6.0.13, 6.1.11 or later.
Description
Spring WebFlux applications that have Spring Security authorization rules on static resources can be bypassed under certain circumstances.
For this to impact an application, all of the following must be true:
- It must be a WebFlux application
- It must be using Spring's static resources support
- It must have a non-permitAll authorization rule applied to the static resources support
NVD description
Spring WebFlux applications that have Spring Security authorization rules on static resources can be bypassed under certain circumstances.
For this to impact an application, all of the following must be true:
* It must be a WebFlux application
* It must be using Spring's static resources support
* It must have a non-permitAll authorization rule applied to the static resources support
More vulnerabilities in org.springframework.security:spring-security-web
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free