In short
- CVE-2024-39316 is a MEDIUM (CVSS 6.5) vulnerability affecting rack, rack (rack).
- Chance of exploitation in the next 30 days (EPSS): 0.86%, higher than 58.4% of all vulnerabilities.
- Fix: update to 3.1.5 or later.
| Package | Affected versions | Patched versions |
|---|
| rack RubyGems | ≥ 3.1.0, < 3.1.5
| 3.1.5
|
| rack | ≥ 3.1.0, < 3.1.5
| 3.1.5
|
Description
Summary
A Regular Expression Denial of Service (ReDoS) vulnerability exists in the Rack::Request::Helpers module when parsing HTTP Accept headers. This vulnerability can be exploited by an attacker sending specially crafted Accept-Encoding or Accept-Language headers, causing the server to spend excessive time processing the request and leading to a Denial of Service (DoS).
Details
The fix for https://github.com/rack/rack/security/advisories/GHSA-54rr-7fvw-6x8f was not applied to the main branch and thus while the issue was fixed for the Rack v3.0 release series, it was not fixed in the v3.1 release series until v3.1.5.
NVD description
Rack is a modular Ruby web server interface. Starting in version 3.1.0 and prior to version 3.1.5, Regular Expression Denial of Service (ReDoS) vulnerability exists in the `Rack::Request::Helpers` module when parsing HTTP Accept headers. This vulnerability can be exploited by an attacker sending specially crafted `Accept-Encoding` or `Accept-Language` headers, causing the server to spend excessive time processing the request and leading to a Denial of Service (DoS). The fix for CVE-2024-26146 was not applied to the main branch and thus while the issue was fixed for the Rack v3.0 release series, it was not fixed in the v3.1 release series until v3.1.5. Users of versions on the 3.1 branch should upgrade to version 3.1.5 to receive the fix.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free