In short
- CVE-2024-39319 is a MEDIUM (CVSS 5.3) vulnerability affecting aimeos/ai-controller-frontend, aimeos frontend controller (aimeos).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.9% of all vulnerabilities.
- Fix: update to 2021.10.8, 2022.10.8, 2023.10.9, 2024.04.2 or later.
| Package | Affected versions | Patched versions |
|---|
| aimeos/ai-controller-frontend Packagist | ≥ 2021.04.1, < 2021.10.8≥ 2022.04.1, < 2022.10.8≥ 2023.04.1, < 2023.10.9≥ 2024.04.1, < 2024.04.2< 2020.10.15
| 2021.10.82022.10.82023.10.92024.04.22020.10.15
|
| aimeos frontend controller | = 2024.04.1≥ 2021.04.1, < 2021.10.8≥ 2022.04.1, < 2022.10.8≥ 2023.04.1, < 2023.10.9< 2020.10.15
| 2021.10.82022.10.82023.10.92020.10.15
|
Description
Impact
Insecure direct object reference allowing an attacker to disable subscriptions and reviews of another customer
NVD description
aimeos/ai-controller-frontend is the Aimeos frontend controller package for e-commerce projects. Prior to versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15, an insecure direct object reference allows an attacker to disable subscriptions and reviews of another customer. Versions 2024.4.2, 2023.10.9, 2022.10.8, 2021.10.8, and 2020.10.15 fix this issue.
More vulnerabilities in aimeos/ai-controller-frontend
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free