In short
- CVE-2024-39322 is a MEDIUM (CVSS 5.5) vulnerability affecting aimeos/ai-admin-jsonadm, ai-controller-frontend (aimeos project).
- Chance of exploitation in the next 30 days (EPSS): 0.48%, higher than 41.7% of all vulnerabilities.
- Fix: update to 2021.10.6, 2022.10.3, 2023.10.4, 2024.04.2 or later.
| Package | Affected versions | Patched versions |
|---|
| aimeos/ai-admin-jsonadm Packagist | ≥ 2021.04.1, < 2021.10.6≥ 2022.04.1, < 2022.10.3≥ 2023.04.1, < 2023.10.4≥ 2024.04.1, < 2024.04.2< 2020.10.13
| 2021.10.62022.10.32023.10.42024.04.22020.10.13
|
| ai-controller-frontend | = 2024.04.1≥ 2021.04.1, < 2021.10.6≥ 2022.04.1, < 2022.10.3≥ 2023.04.1, < 2023.10.4< 2020.10.13
| 2021.10.62022.10.32023.10.42020.10.13
|
Description
Improper access control allows editors to remove admin group and locale configuration in Aimeos backend
NVD description
aimeos/ai-admin-jsonadm is the Aimeos e-commerce JSON API for administrative tasks. In versions prior to 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2, improper access control allows editors to remove admin group and locale configuration in the Aimeos backend. Versions 2020.10.13, 2021.10.6, 2022.10.3, 2023.10.4, and 2024.4.2 contain a fix for the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free