In short
- CVE-2024-39338 is a HIGH (CVSS 7.5) vulnerability affecting axios (axios), axios.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.3% of all vulnerabilities.
- Fix: update to 1.7.4 or later.
| Package | Affected versions | Patched versions |
|---|
| axios | ≥ 1.3.2, < 1.7.4
| 1.7.4
|
| axios npm | ≥ 1.3.2, < 1.7.4
| 1.7.4
|
Description
axios 1.7.2 allows SSRF via unexpected behavior where requests for path relative URLs get processed as protocol relative URLs.
NVD description
axios 1.7.2 allows SSRF via unexpected behavior where requests for path relative URLs get processed as protocol relative URLs.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free