In short
- CVE-2024-39689 is a HIGH (CVSS 7.5) vulnerability affecting certifi, certifi (certifi), ontap tools (netapp).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 64.3% of all vulnerabilities.
- Fix: update to 2024.7.4 or later.
| Package | Affected versions | Patched versions |
|---|
| certifi PyPI | ≥ 2021.5.30, < 2024.7.4
| 2024.7.4
|
| certifi | ≥ 2021.5.30, < 2024.7.4
| 2024.7.4
|
| ontap tools | = 10
| No fix yet |
Description
Certifi 2024.07.04 removes root certificates from "GLOBALTRUST" from the root store. These are in the process of being removed from Mozilla's trust store.
GLOBALTRUST's root certificates are being removed pursuant to an investigation which identified "long-running and unresolved compliance issues". Conclusions of Mozilla's investigation can be found here.
NVD description
Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi starting in 2021.5.30 and prior to 2024.7.4 recognized root certificates from `GLOBALTRUST`. Certifi 2024.7.04 removes root certificates from `GLOBALTRUST` from the root store. These are in the process of being removed from Mozilla's trust store. `GLOBALTRUST`'s root certificates are being removed pursuant to an investigation which identified "long-running and unresolved compliance issues."
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free