In short
- CVE-2024-39705 is a CRITICAL (CVSS 9.8) vulnerability affecting nltk.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.4% of all vulnerabilities.
- Fix: update to 3.9 or later.
| Package | Affected versions | Patched versions |
|---|
| nltk PyPI | < 3.9
| 3.9
|
Description
NLTK through 3.8.1 allows remote code execution if untrusted packages have pickled Python code, and the integrated data package download functionality is used. This affects, for example, averaged_perceptron_tagger and punkt.
NVD description
NLTK through 3.8.1 allows remote code execution if untrusted packages have pickled Python code, and the integrated data package download functionality is used. This affects, for example, averaged_perceptron_tagger and punkt.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free