In short
- CVE-2024-40453 is a CRITICAL (CVSS 9.8) vulnerability affecting squirrelly (squirrelly), squirrelly.
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.3% of all vulnerabilities.
- Fix: update to 9.1.0 or later.
| Package | Affected versions | Patched versions |
|---|
| squirrelly | = 9.0.0
| No fix yet |
| squirrelly npm | ≥ 9.0.0, < 9.1.0
| 9.1.0
|
Description
squirrellyjs squirrelly v9.0.0 was discovered to contain a code injection vulnerability via the component options.varName. The issue was fixed in version 9.1.0.
NVD description
squirrellyjs squirrelly v9.0.0 and fixed in v.9.0.1 was discovered to contain a code injection vulnerability via the component options.varName.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free