In short
- CVE-2024-40632 is a LOW (CVSS 3.7) vulnerability affecting github.com/linkerd/linkerd2.
- Chance of exploitation in the next 30 days (EPSS): 0.44%, higher than 38.7% of all vulnerabilities.
- Fix: update to 0.5.1-0.20240614165515-35fb2d6d11ef or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/linkerd/linkerd2 Go | < 0.5.1-0.20240614165515-35fb2d6d11ef
| 0.5.1-0.20240614165515-35fb2d6d11ef
|
Description
Linkerd potential access to the shutdown endpoint in github.com/linkerd/linkerd2
NVD description
Linkerd is an open source, ultralight, security-first service mesh for Kubernetes. In affected versions when the application being run by linkerd is susceptible to SSRF, an attacker could potentially trigger a denial-of-service (DoS) attack by making requests to localhost:4191/shutdown. Linkerd could introduce an optional environment variable to control a token that must be passed as a header. Linkerd should reject shutdown requests that do not include this header. This issue has been addressed in release version edge-24.6.2 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
More vulnerabilities in github.com/linkerd/linkerd2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free