In short
- CVE-2024-4068 is a HIGH (CVSS 7.5) vulnerability affecting braces (jonschlinkert), braces.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 73.9% of all vulnerabilities.
- Fix: update to 3.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| braces | < 3.0.3
| 3.0.3
|
| braces npm | < 3.0.3
| 3.0.3
|
Description
The NPM package braces fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In lib/parse.js, if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash.
NVD description
The NPM package `braces`, versions prior to 3.0.3, fails to limit the number of characters it can handle, which could lead to Memory Exhaustion. In `lib/parse.js,` if a malicious user sends "imbalanced braces" as input, the parsing will enter a loop, which will cause the program to start allocating heap memory without freeing it at any moment of the loop. Eventually, the JavaScript heap limit is reached, and the program will crash.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free