In short
- CVE-2024-40761 is a MEDIUM (CVSS 5.3) vulnerability affecting github.com/apache/incubator-answer, answer (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.75%, higher than 54.9% of all vulnerabilities.
- Fix: update to 1.4.0 or later.
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
NVD description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.3.5.
Using the MD5 value of a user's email to access Gravatar is insecure and can lead to the leakage of user email. The official recommendation is to use SHA256 instead.
Users are recommended to upgrade to version 1.4.0, which fixes the issue.
More vulnerabilities in github.com/apache/incubator-answer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free