In short
- CVE-2024-41674 is a MEDIUM (CVSS 5.3) vulnerability affecting ckan, ckan (okfn).
- Chance of exploitation in the next 30 days (EPSS): 0.38%, higher than 32.1% of all vulnerabilities.
- Fix: update to 2.10.5 or later.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.0.0, < 2.10.5
| 2.10.5
|
| ckan | ≥ 2.0, < 2.10.5
| 2.10.5
|
Description
If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to package_search calls as part of the returned error message
Patches
This has been patched in CKAN 2.10.5 and 2.11.0
NVD description
CKAN is an open-source data management system for powering data hubs and data portals. If there were connection issues with the Solr server, the internal Solr URL (potentially including credentials) could be leaked to package_search calls as part of the returned error message. This has been patched in CKAN 2.10.5 and 2.11.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free