In short
- CVE-2024-42357 is a CRITICAL (CVSS 9.8) vulnerability affecting shopware/core, shopware/platform, shopware (shopware).
- Chance of exploitation in the next 30 days (EPSS): 0.60%, higher than 48.8% of all vulnerabilities.
- Fix: update to 6.6.5.1, 6.5.8.13 or later.
| Package | Affected versions | Patched versions |
|---|
| shopware/core Packagist | ≥ 6.6.0.0, < 6.6.5.1< 6.5.8.13
| 6.6.5.16.5.8.13
|
| shopware/platform Packagist | ≥ 6.6.0.0, < 6.6.5.1< 6.5.8.13
| 6.6.5.16.5.8.13
|
| shopware | ≥ 6.6.0.0, < 6.6.5.1< 6.5.8.13
| 6.6.5.16.5.8.13
|
Description
Impact
The Shopware application API contains a search functionality which enables users to search through information stored within their Shopware instance. The searches performed by this function can be aggregated using the parameters in the “aggregations”
object. The ‘name’ field in this “aggregations” object is vulnerable SQL-injection and can be exploited using SQL parameters.
Patches
Update to Shopware 6.6.5.1 or 6.5.8.13
Workarounds
For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Credit
LogicalTrust
NVD description
Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the Shopware application API contains a search functionality which enables users to search through information stored within their Shopware instance. The searches performed by this function can be aggregated using the parameters in the `aggregations` object. The `name` field in this `aggregations` object is vulnerable SQL-injection and can be exploited using SQL parameters. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3, and 6.4, corresponding security measures are also available via a plugin.
More vulnerabilities in shopware/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free