In short
- CVE-2024-42360 is a CRITICAL (CVSS 9.8) vulnerability affecting sequenceserver, sequenceserver (wurmlab).
- Chance of exploitation in the next 30 days (EPSS): 0.58%, higher than 48.2% of all vulnerabilities.
- Fix: update to 3.1.2 or later.
Description
Impact
Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands
Patches
Fixed in 3.1.2
Workarounds
No known workarounds
NVD description
SequenceServer lets you rapidly set up a BLAST+ server with an intuitive user interface for personal or group use. Several HTTP endpoints did not properly sanitize user input and/or query parameters. This could be exploited to inject and run unwanted shell commands. This vulnerability has been fixed in 3.1.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free