In short
- CVE-2024-42461 is a CRITICAL (CVSS 9.1) vulnerability affecting elliptic (elliptic project), elliptic.
- Chance of exploitation in the next 30 days (EPSS): 0.62%, higher than 49.7% of all vulnerabilities.
- Fix: update to 6.5.7 or later.
| Package | Affected versions | Patched versions |
|---|
| elliptic | = 6.5.6
| No fix yet |
| elliptic npm | ≥ 5.2.1, < 6.5.7
| 6.5.7
|
Description
In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because BER-encoded signatures are allowed.
NVD description
In the Elliptic package 6.5.6 for Node.js, ECDSA signature malleability occurs because BER-encoded signatures are allowed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free